Eclipse STS and Dynamic Web Module Versions

Noticed after updating to the latest that I had yet another error. This time, doing a maven project update it said it couldn’t update the Dynamic Web Module to 2.5 and it showed it set at 3.0. Our projects are set up for 3.0.

Unfortunately, I don’t remember which sites I got this tip from, but … what did to fix it was pretty straight-forward. Just right-click and bring up the project properties; select Project Facet and deselect the Dynamic Web Module; click okay to exit the dialog. Now re-run the maven “Update Project” and you’ll see the error disappear. Checking the Project Facets, you’ll see the Dynamic Web Module set to the proper version (2.5, in my case).

Advertisements

About John Woodward

Principal Consultant at Improving Enterprises, Inc.
This entry was posted in Software and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s